HomeGuidesAPI Reference
Submit Documentation FeedbackJoin Developer CommunityOptimizely GitHubOptimizely NuGetLog In

Install SDK

This topic describes the steps necessary to install the Optimizely React Native SDK.

The React Native SDK can be used in both ReactJS and React Native environments and is distributed through npm. The React SDK supports datafile caching and offline events persistence for React Native applications. Add it to your package with NPM:

npm install --save @optimizely/react-sdk

or with Yarn:

yarn add @optimizely/react-sdk

The full source code is available on GitHub.

Requirements

The React SDK requires an ES5-compatible environment, as well as Promise. To run in environments that do not support promise, you can use promise-polyfill.

Peer dependencies

To use the features such as datafile caching and offline events persistence, you need to install the following peer dependencies in your React Native application.

yarn add @react-native-async-storage/async-storage
yarn add @react-native-community/netinfo

`@react-native-async-storage/async-storage is required to:

  • enable datafile caching by storing the datafile on the user's device.
  • enable event offline persistence by temporarily storing events on user's device when offline.

@react-native-community/netinfo is required to detect when internet connectivity is restored, so that events triggered during the offline mode can be retried.


Did this page help you?